Users unable to access Unit21

Incident Report for Unit21 Multitenant US-Prod1

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 11:40 UTC

Identified

We identified that this issue is caused by Amazon CloudFront outage (https://health.aws.amazon.com/health/status).
Posted Jul 16, 2026 - 09:41 UTC

Investigating

We are currently investigating issues with users unable to access Unit21
Posted Jul 16, 2026 - 08:36 UTC