Transaction Screening Issues

Incident Report for Unit21 Multitenant US-Prod1

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 16:33 UTC

Investigating

We are currently investigating issues with the transaction screening endpoint.
Posted Jul 14, 2026 - 15:41 UTC
This incident affected: Real Time Payments Screening.