Databricks Outage

Incident Report for Unit21 Multitenant US-Prod1

Resolved

Databricks have restored their services. Incident has been resolved.
Posted Mar 30, 2026 - 23:44 UTC

Identified

Databricks Compute and Lakeflow is down.
This impacts the following features:
- file exports
- watchlist
We are monitoring updates from Databricks.
Posted Mar 30, 2026 - 22:07 UTC
This incident affected: File Exports.